WordPress升级2.8错误的解决方法

WordPress的2.8版本已经出来很久了,可自从上次升级失败后就一直没有再升级过。虽然之前查过很多方法,比如不要自动安装,而是手工下载安装就不会有问题,但我真的很懒,于是一直拖到现在。不过每次打开wordpress后都看到烦人的升级提示也不是办法,遂刚刚忍不住继续点击了“自动升级”,问题依旧:

Fatal error: Allowed memory size of 33554432 bytes exhausted…

于是在官网找了个Wordpress升级错误的解决方案,并顺利解决了这个问题:

1. Download, back up and open: wp-settings.php in wordpad/notepad
2. Search for define(’WP_MEMORY_LIMIT’, ‘32M’);
3. Change 32M to 64M : define(’WP_MEMORY_LIMIT’, ‘64M’);
4. Enjoy

简单的说就是打开虚拟空间的Cpanel,进入文件管理器,找到博客安装目录中的“wp-settings.php”文件,编辑(记得使用utf-8模式)打开这个文件,修改’WP_MEMORY_LIMIT’, ‘32M’为’WP_MEMORY_LIMIT’, ‘64M’,保存即可。随后回到Wordpress后台,点击“自动升级”,问题完美解决。当然,如果没有升级彻底,那么继续重复这个步骤(我修改并升级了2次才将Wordpress升级到最新版)。

需要注意的是,升级成功后,wp-settings.php文件会被替换回之前的样子,即“32M”,这时如果你发布文章,系统会继续提醒你“Allowed memory size of 33554432 bytes exhausted”错误,你需要将wp-settings.php文件再次修改到‘64M’才可以。这个问题主要是Wordpress对中文的支持(兼容性)不够引起的,希望在以后的版本能够得到解决。

安装zoundry raven离线客户端时出现error fetching list of blogs错误的问题

zoundry raven 是一款非常强大的博客离线发布工具,我在对比了 windows live writer 等离线客户端后,决定尝试使用 zoundry raven,并在需要时使用该客户端发布我的博客。毕竟 wordpress 的后台太慢了,对于我这样的慢性子而言都已经无法忍受。并且zoundry raven 的编写系统也足够强大易用。

zoundry raven 为需要的客户提供免费的下载服务,如果你也需要,不妨试试。

但是在我安装 zoundry raven 的过程中,输入帐号密码后出现”error fetching list of blogs”,链接错误?输错密码?我一头雾水下,在网上查阅了一些资料,发现原来是个很简单的问题。

原来,wordpress 2.6版本之后,系统默认设置”不支持远程发布”。这时只需要进入系统后台,找到设置 – 撰写 – 远程发布,将XML-RPC后的对勾打上即可。

再次输入 zoundry raven 登录名(随意),wordpress后台登录名和密码,连接成功!问题圆满解决了。本文用 zoundry raven 发布。

ps.实际上,本篇经过zoundry raven发布时,我是设置为“发送到草稿”,随后登录 wordpress 进行二次编辑的。修改的内容包括:URL链接;图像名称;ping网站;重建sitemap等。另外,我发现分类目录无法正常设置为所需分类,难道是我设置为草稿的缘故?我会继续测试的。